Reading Time: 2 minutes

Like every hardware and software components, before apply a VMware vSphere upgrade or update you have to check all compatibility aspects.

One is related to the backup software that can be critical because you may loose the capability to perform backup and/or restore.

For Veeam Backup & Replication there is a specific Veeam KB (KB 2443) that provides information about compatibility between VMware vSphere and Veeam Backup & Replication.

The Veeam KB consider also old version of Veeam Backup, but according to the Veeam Product Lifecycle Policy, actually only Veeam Backup 12 is fully supported (Veeam Backup 11 went end of support on February 2024).

vSphere versionVeeam VBR 12Veeam VBR 11
vSphere 8.0.3Not yet supportedNot supported
vSphere 8.0.2Fully supported from 12.1 (build 12.1.0.2131)Not supported
vSphere 8.0.1Supported from 12 P20230412 (build 12.0.0.1420 P20230412)Not supported
vSphere 8.0Supported from 12 (build 12.0.0.1420)Supported from 11a P20220302 but with limitations
vSphere 7.0.3Fully supportedSupported from 11a (build 11.0.1.1261)
vSphere 7.0.2
Fully supported
Supported from 11 P20210525  (build 11.0.0.837 P20210525)
vSphere 7.0/7.0.1
Fully supported

Fully supported
vSphere 6.7Supported*Supported*
vSphere 6.5Supported*Supported*
vSphere 6.0Supported*Supported*
vSphere 5.5Not supportedUntil 11a P20230227*
vSphere 5.1Not supportedNot supported

*Please note that all vSphere versions before 7.0 are gone out of support by VMware.

A list of Veeam Backup & Replication version and build numbers can be found on Veeam KB 2680
A list of VMware ESX(i) versions and their respective build numbers can be found on VMware KB 2143832.

Share