This post is also available in: Italian

During the upgrade to Workstation 8.0.2 (on 64 bit Windows 7 OS) I’ve got a curios issue that I want to share.

Basically for some strange reason the previous version was not removed correctly and the new one was not able to install itself because the setup program fail during the old version check. Also from control panel was not possible remove the old package.

The documented (from the command line prompt) option in the exe file does not resolve this issue (also with the /clean option). And the manual remove of previous version was not possible in a fast way (delete files, registry entries and device drives was not enough…).

The solution was on Ulli Hankeln web site in the Workstation FAQ area:

Error message: “The MSI fails”
this only applies to new installations of Workstation 7 or VMplayer 3 – not updates run setup like this

Although the description does not match may issue one of the error message was the same and using this command I’ve fixed the system and install the new version of Workstation:

VMware-workstation-full-8.0.2-591240 /z “action”=”install”

This post has already been read 1962 times.

Andrea MauroAbout Andrea Mauro (2737 Posts)

Virtualization, Cloud and Storage Architect. Tech Field delegate. VMUG IT Co-Founder and board member. VMware VMTN Moderator and vExpert 2010-18. Dell TechCenter Rockstar 2014-15. Microsoft MVP 2014-16. Veeam Vanguard 2015-18. Nutanix NTC 2014-18. PernixPro 2014-16. Several certifications including: VCDX-DCV, VCP-DCV/DT/Cloud, VCAP-DCA/DCD/CIA/CID/DTA/DTD, MCSA, MCSE, MCITP, CCA, NPP.


Share