Questo post è disponibile anche in: Inglese

Reading Time: 3 minutes

Anche dopo quasi due mesi dall’usita del nuovo vSphere 6.0, una delle principali ragioni per non aggiornare (o non utilizzarlo ancora in produzione) è legata alla compatibilità dei prodotto. Se per l’hardware basta guardare l’HCL e per il software VMware quasi tutto è diventato compatibile (almeno nelle ultime versioni dei vari prodotti), lo stesso non si può dire per i programmi di backup.

La settimana scorsa ero all’evento VMUG londinese e in effetti pure lì (che come realtà si avvicina molto a quella americana) pochissimi stavano già usando vSphere 6.0 in produzione (l’Italia non fa testo, visto che c’è ancora chi ha in produzione vSphere 4.x che è end of support già da parecchio tempo). Il motivo principare era proprio legato alla compatibilità.

Un mese fa avevo stilato una lista dei software di backup e del loro grado di compatibilità con vSphere (vedere il post Compatibilità tra vSphere 6.0 e i programmi di backup).

Ora questa lista si è completata con sempre più programmi compatibili con vSphere 6.0:

vSphere 5.0 vSphere 5.1 vSphere 5.5 vSphere 6.0
VMware vSphere Data Protection 6.0Compatibility No Yes (only hosts) Yes (only hosts) Yes
Veeam Backup & Replication 8Compatibility Yes Yes Yes 8.0SP2
Veeam Backup & Replication 7 Yes Yes Yes (7R2) No
Symantec Backup Exec 15 No Yes Yes Yes
Symantec Backup Exec 2014 SP2Compatibility Yes Yes Yes only v2015?
Symantec Backup Exec 2012 SP4 Yes Yes Yes (SP3) No?
Symantec Netbackup 7.6Compatibility Yes Yes Yes (7.6.1) v7.6.1.1
Unitrends Enterprise Backup Yes Yes Yes (7.3) ?
Unitrends Virtual Backup (formerly PHD Virtual Backup) Yes Yes Yes (8.0) ?
Acronis Backup (formerly vmProtect) for VMware Yes Yes Yes (9.0U1) v9.0U2
Acronis Backup Advanced for VMware 11.5 Yes Yes Yes ?
IBM Tivoli Storage Manager for Virtual Environments: Data Protection for VMware 7.1 Yes Yes Yes v7.1.2
Nakivo Backup & Replication 5.x Yes Yes Yes ?
Nakivo Backup & Replication 3.x and 4.x Yes Yes Yes (3.8) No
CommVault Simpana 10R2 Yes Yes Yes (10.0 SP5) 10.0 R2
HP Data Protector Yes Yes Yes June/July?
Dell Software (formerly Quest/Vizioncore) vRanger Yes Yes Yes (7.0) ?
Quantum vmPRO VM Data Protection Software Yes Yes Yes ?
EMC Amavar Yes Yes Yes (7.0SP1) Aug?
EMC (formerly Legato) Networker 8.x Yes Yes Yes (8.1SP1) Aug?
CA ARCserve Yes Yes Yes (r16.5) ?
WD Arkeia VMware vStorage Backup Agent Yes Yes Yes ?
Zmanda Client for VMware vSphere Yes Yes Yes ?
Barracuda Backup (BU) Yes Yes Yes Yes
Trilead VM Explorer 5.x Yes Yes Yes (5.0.012) 5.3.006

Questa tabella prevede solo prodotti che utilizzino le VMware VADP API. Questo perché, come già detto, altre soluzioni basate su agenti richiedono fondamentalmente solo la compatibilità con il sistema operativo della VM. Nella tabella non sono neanche elencati prodotto che oramai sono fuori supporto o fuori ciclo di vita (ad esempio VDR).

Notare che vi è un problema molto serio nella gestione del CBT di ESXi 6.0 che potrebbe compromettere i programmi di backup (anche se compatibili con vSphere 6.0): per maggiori informazioni vedere la KB 2114076 (Backing up a virtual machine with Change Block Tracking (CBT) enabled fails after upgrading to or installing VMware ESXi 6.0).

Da segnalare che Manfred Hofer ha realizzato una una comparazione veramente ben fatta (e che include anche la compatibilità con Microsoft Hyper-V). Per maggiori informazioni vedere: Backup Interoperability Matrix.

Dove vi è un punto di domanda semplicemente non sono state rilasciate (ancora) informazioni più o meno ufficiali… Ovviamente nei prossimi mesi questa tabella cambierà ancora, ma già da ora è decisamente più interessante.

Se avete altre informazioni lasciate un commento a questo post.

Andrea MauroAbout Andrea Mauro (2909 Posts)

Virtualization, Cloud and Storage Architect. Tech Field delegate. VMUG IT Co-Founder and board member. VMware VMTN Moderator and vExpert 2010-18. Dell TechCenter Rockstar 2014-15. Microsoft MVP 2014-16. Veeam Vanguard 2015-18. Nutanix NTC 2014-18. PernixPro 2014-16. Several certifications including: VCDX-DCV, VCP-DCV/DT/Cloud, VCAP-DCA/DCD/CIA/CID/DTA/DTD, MCSA, MCSE, MCITP, CCA, NPP.


Related Post:

Share